• cdanger's avatar
    - POM: changed parent version: 3.4.0 -> 4.0.0 · 15f43c13
    cdanger authored
    - POM: changed project version: 5.0.3-SNAPSHOT -> 6.0.0
    - POM: changed dep version: authzforce-ce-core-pdp-api 7.1.2-SNAPSHOT ->
    8.0.0-SNAPSHOT
    - POM: added owasp-dependency-check plugin
    - Replaced classes (Ordered)Deny/PermitOverridesCombiningAlg with
    DPOverridesCombiningAlg
    - Replaced classes Deny/PermitUnlessPermit/DenyCombiningAlg with
    DPUnlessPDCombiningAlg 
    - LogicalNOfFunction: first parameter (minimum of TRUE arguments to
    return TRUE) checked at Apply parsing time if constant
    - Substring function: second and third arguments checked at Apply
    parsing time if constant (arg1 >= 0, arg2 == -1 || arg2 >= arg1)
    - XACML Condition: expression checked whether constant FALSE -> illegal
    (or TRUE -> optimized)
    - Fixed issues with unit tests 
    15f43c13
owasp-dependency-check-suppression.xml 347 Bytes