Commit 7d645226 authored by Emmanuel Duchastenier's avatar Emmanuel Duchastenier Committed by GitHub
Browse files

tr(packaging): remove the token placeholders in web.xml (#344)

* remove the token placeholders that were used by IT tests in bonita-web-sp module
* remote portal is not allowed anymore so bonita.war(-sp) already contains bonita-engine(-sp)
* fix up some transitive dependency version
parent 7983e612
......@@ -15,11 +15,6 @@
<deploy_plugin_skip>true</deploy_plugin_skip>
<folder_frontend_web_resources>${project.build.directory}/bonita-frontend</folder_frontend_web_resources>
<folder_frontend_web_config_files>${project.build.directory}/bonita-frontend-config</folder_frontend_web_config_files>
<!-- Required to filter the web.xml file -->
<enable.engine.http.api.start />
<enable.engine.http.api.end />
<enable.engine.listener.start />
<enable.engine.listener.end />
<!-- Required to filter the VERSION file -->
<build.year>${maven.build.timestamp}</build.year>
<maven.build.timestamp.format>yyyy</maven.build.timestamp.format>
......@@ -49,26 +44,6 @@
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>org.bonitasoft.engine</groupId>
<artifactId>bonita-server</artifactId>
<version>${bonita.engine.version}</version>
<exclusions>
<exclusion>
<artifactId>jboss-logging</artifactId>
<groupId>org.jboss.logging</groupId>
</exclusion>
<exclusion>
<artifactId>activation</artifactId>
<groupId>javax.activation</groupId>
</exclusion>
<exclusion>
<artifactId>jta</artifactId>
<groupId>javax.transaction</groupId>
</exclusion>
</exclusions>
</dependency>
</dependencies>
<build>
......
......@@ -58,6 +58,24 @@
<version>${slf4j.version}</version>
<scope>runtime</scope>
</dependency>
<!-- to make sure transitive dependencies do not select a different version: -->
<dependency>
<groupId>commons-logging</groupId>
<artifactId>commons-logging</artifactId>
<version>1.2</version>
</dependency>
<dependency>
<groupId>commons-codec</groupId>
<artifactId>commons-codec</artifactId>
<version>1.11</version>
</dependency>
<dependency>
<groupId>commons-collections</groupId>
<artifactId>commons-collections</artifactId>
<version>3.2.2</version>
</dependency>
</dependencies>
</dependencyManagement>
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment