Unverified Commit 965e3ec2 authored by Benjamin Parisel's avatar Benjamin Parisel Committed by GitHub
Browse files

chore(dependencies): bump angular dependencies (#126)

* remove warning on npm install for generated app
* run server with node 16.13.0 for preview
* bump angular dependencies to use angular-cli in 13.0.2
parent 388ede39
......@@ -9,25 +9,25 @@
},
"private": true,
"dependencies": {
"@angular/animations": "~12.0.3",
"@angular/common": "~12.0.3",
"@angular/compiler": "~12.0.3",
"@angular/core": "~12.0.3",
"@angular/forms": "~12.0.3",
"@angular/platform-browser": "~12.0.3",
"@angular/platform-browser-dynamic": "~12.0.3",
"@angular/router": "~12.0.3",
"@angular/animations": "~13.0.1",
"@angular/common": "~13.0.1",
"@angular/compiler": "~13.0.1",
"@angular/core": "~13.0.1",
"@angular/forms": "~13.0.1",
"@angular/platform-browser": "~13.0.1",
"@angular/platform-browser-dynamic": "~13.0.1",
"@angular/router": "~13.0.1",
"@bonitasoft/ui-designer-context-binding": "0.0.12",
"rxjs": "~6.6.0",
"tslib": "^2.1.0",
"zone.js": "~0.11.4"
},
"devDependencies": {
"@angular-devkit/build-angular": "~12.0.3",
"@angular/cli": "~12.0.3",
"@angular/compiler-cli": "~12.0.3",
"@angular-devkit/build-angular": "~13.0.1",
"@angular/cli": "~13.0.1",
"@angular/compiler-cli": "~13.0.1",
"@types/node": "^12.11.1",
"jasmine-core": "~3.7.0",
"typescript": "~4.2.3"
"typescript": "~4.4.4"
}
}
......@@ -9,8 +9,8 @@
<description>Angular generated app for UI Designer</description>
<properties>
<node.version>v14.17.6</node.version>
<npm.version>6.14.15</npm.version>
<node.version>v16.13.0</node.version>
<npm.version>8.1.0</npm.version>
<frontend-maven-plugin.version>1.12.0</frontend-maven-plugin.version>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<project.scm.id>github</project.scm.id>
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment