Commit 2e6f3e87 authored by Dorian Guillois's avatar Dorian Guillois
Browse files

Update documentation.

parent 44593e9f
......@@ -19,22 +19,25 @@ repository.
These packages have been successfully tested with CentOS 5 and RedHat 5.
.. _user_installation_packages_prerequisites:
Prerequisites
=============
In order to use RPM from the CES repository, you have to install the
appropriate repo file. Run the following command as privileged user ::
$ wget http://yum.centreon.com/standard/ces-standard.repo -O /etc/yum.repos.d/ces-standard.repo
$ wget http://yum.centreon.com/standard/2.2/ces-standard.repo -O /etc/yum.repos.d/ces-standard.repo
The repo file is now installed. Don't forget to cleanup ::
The repo file is now installed.
$ yum clean all
Install
=======
Run the following commands as privileged user ::
$ yum clean all
$ yum install centreon-connector-perl
All dependencies are automatically installed from Merethis repositories.
......@@ -84,22 +87,18 @@ Perl perl Scripting language.
#. Install basic compilation tools ::
$ yum install gcc gcc-c++ make perl
$ yum install perl-devel perl-ExtUtils-Embed # Only for CentOS 6
#. Get and install cmake
$ yum install gcc gcc-c++ make perl
$ yum install perl-devel perl-ExtUtils-Embed # Only for CentOS 6
For CentOS 5 ::
#. Install Merethis repository
$ ARCH=`uname -m`
$ wget http://apt.sw.be/redhat/el5/en/${ARCH}/extras/RPMS/cmake-2.8.8-1.el5.rfx.${ARCH}.rpm
$ rpm -Uvh cmake-2.8.8-1.el5.rfx.${ARCH}.rpm
You need to install Centreon Entreprise Server (CES) repos file as
explained :ref:`user_installation_packages_prerequisites` to use some
specific package version.
For CentOS 6 ::
#. Install cmake ::
$ ARCH=`uname -m`
$ wget http://apt.sw.be/redhat/el6/en/${ARCH}/extras/RPMS/cmake-2.8.8-1.el6.rfx.${ARCH}.rpm
$ rpm -Uvh cmake-2.8.8-1.el6.rfx.${ARCH}.rpm
$ yum install cmake
#. Install Centreon Clib
......
......@@ -2,7 +2,7 @@
Installation
############
Merethis recommend using its official packages from the Centreon
Merethis recommends using its official packages from the Centreon
Entreprise Server (CES) repository. Most of Merethis' endorsed
software are available as RPM packages.
......@@ -19,22 +19,25 @@ repository.
These packages have been successfully tested with CentOS 5 and RedHat 5.
.. _user_installation_packages_prerequisites:
Prerequisites
=============
In order to use RPM from the CES repository, you have to install the
appropriate repo file. Run the following command as privileged user ::
$ wget http://yum.centreon.com/standard/ces-standard.repo -O /etc/yum.repos.d/ces-standard.repo
$ wget http://yum.centreon.com/standard/2.2/ces-standard.repo -O /etc/yum.repos.d/ces-standard.repo
The repo file is now installed. Don't forget to cleanup ::
The repo file is now installed.
$ yum clean all
Install
=======
Run the following commands as privileged user ::
$ yum clean all
$ yum install centreon-connector-ssh
All dependencies are automatically installed from Merethis repositories.
......@@ -84,21 +87,17 @@ gcrypt library libgcrypt-devel Gcrypt library.
#. Install basic compilation tools ::
$ yum install gcc gcc-c++ make libssh2-devel libgcrypt-devel
#. Get and install cmake
$ yum install gcc gcc-c++ make libssh2-devel libgcrypt-devel
For CentOS 5 ::
#. Install Merethis repository
$ ARCH=`uname -m`
$ wget http://apt.sw.be/redhat/el5/en/${ARCH}/extras/RPMS/cmake-2.8.8-1.el5.rfx.${ARCH}.rpm
$ rpm -Uvh cmake-2.8.8-1.el5.rfx.${ARCH}.rpm
You need to install Centreon Entreprise Server (CES) repos file as
explained :ref:`user_installation_packages_prerequisites` to use some
specific package version.
For CentOS 6 ::
#. Install cmake ::
$ ARCH=`uname -m`
$ wget http://apt.sw.be/redhat/el6/en/${ARCH}/extras/RPMS/cmake-2.8.8-1.el6.rfx.${ARCH}.rpm
$ rpm -Uvh cmake-2.8.8-1.el6.rfx.${ARCH}.rpm
$ yum install cmake
#. Install Centreon Clib
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment