Commit 7e61a803 authored by Munilla Christophe's avatar Munilla Christophe

fix "Could not resolve dependencies for project...

fix "Could not resolve dependencies for project org.ow2.frascati.nuxeo:frascati-service-bridge-api:jar:1.5-SNAPSHOT" error: exclude org.osgi:osgi-core:4.1 transitive dependency - replace it by the org.osgi:org.osgi.core:4.2.0:provided one
parent 85accc09
......@@ -53,6 +53,18 @@
<artifactId>nuxeo-runtime</artifactId>
<version>${nuxeo.version}</version>
<scope>provided</scope>
<exclusions>
<exclusion>
<groupId>org.osgi</groupId>
<artifactId>osgi-core</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>org.osgi</groupId>
<artifactId>org.osgi.core</artifactId>
<version>4.2.0</version>
<scope>provided</scope>
</dependency>
</dependencies>
......
......@@ -19,38 +19,6 @@
<name>OW2 FraSCAti SCA Component API for Nuxeo</name>
<dependencies>
<!--
<dependency>
<groupId>org.ow2.frascati.model</groupId>
<artifactId>frascati-model</artifactId>
<version>2.0.1.3</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.eclipse.emf</groupId>
<artifactId>ecore</artifactId>
<version>2.4.0</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.ow2.frascati.model</groupId>
<artifactId>osoa-java-api</artifactId>
<version>2.0.1.3</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.nuxeo.runtime</groupId>
<artifactId>nuxeo-runtime-bridge</artifactId>
<version>5.5-SNAPSHOT</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.nuxeo.runtime</groupId>
<artifactId>nuxeo-runtime</artifactId>
<version>${nuxeo.version}</version>
<scope>provided</scope>
</dependency>
-->
</dependencies>
<build>
......
......@@ -42,12 +42,24 @@
<packaging>jar</packaging>
<dependencies>
<dependency>
<groupId>org.nuxeo.runtime</groupId>
<artifactId>nuxeo-runtime</artifactId>
<version>${nuxeo.version}</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.nuxeo.runtime</groupId>
<artifactId>nuxeo-runtime</artifactId>
<version>${nuxeo.version}</version>
<scope>provided</scope>
<exclusions>
<exclusion>
<groupId>org.osgi</groupId>
<artifactId>osgi-core</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>org.osgi</groupId>
<artifactId>org.osgi.core</artifactId>
<version>4.2.0</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.osgi</groupId>
<artifactId>org.osgi.core</artifactId>
......
......@@ -26,7 +26,19 @@
<artifactId>nuxeo-runtime</artifactId>
<version>${nuxeo.version}</version>
<scope>provided</scope>
</dependency>
<exclusions>
<exclusion>
<groupId>org.osgi</groupId>
<artifactId>osgi-core</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>org.osgi</groupId>
<artifactId>org.osgi.core</artifactId>
<version>4.2.0</version>
<scope>provided</scope>
</dependency>
</dependencies>
<build>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment