Commit a8ef3a3f authored by Gwenael Cattez's avatar Gwenael Cattez
Browse files

<frascati-binding-jms> : Setting dependency jgroups:jgroups-all:jar:2.2.8 to...

<frascati-binding-jms> : Setting dependency jgroups:jgroups-all:jar:2.2.8 to org.jgroups:jgroups:jar:2.12.1.Final to avoid conflict with <frascati-binding-jgroups>
Add property <jgroups.version> to prevent that king of conflicts
parent 96e804f4
......@@ -154,6 +154,18 @@
<groupId>org.objectweb.joram</groupId>
<artifactId>jndi-client</artifactId>
<version>${joram.version}</version>
<exclusions>
<exclusion>
<groupId>jgroups</groupId>
<artifactId>jgroups-all</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>org.jgroups</groupId>
<artifactId>jgroups</artifactId>
<version>${jgroups.version}</version>
</dependency>
<dependency>
......
......@@ -92,7 +92,18 @@
<artifactId>frascati-component-factory-julia</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.objectweb.monolog</groupId>
<artifactId>monolog</artifactId>
<version>2.1.12</version>
</dependency>
<dependency>
<groupId>asm</groupId>
<artifactId>asm</artifactId>
<version>3.1</version>
</dependency>
<!-- OW2 FraSCAti Group Communication Metamodel Module. -->
<dependency>
......@@ -104,7 +115,7 @@
<dependency>
<groupId>org.jgroups</groupId>
<artifactId>jgroups</artifactId>
<version>2.12.1.Final</version>
<version>${jgroups.version}</version>
</dependency>
<!-- TODO: remove this dependency to OW2 Fractal Julia. -->
......
......@@ -317,6 +317,7 @@
<xerces.version>2.9.1</xerces.version>
<jaxb.version>2.1.13</jaxb.version>
<velocity.version>1.7</velocity.version>
<jgroups.version>2.12.1.Final</jgroups.version>
<jaxb2.version>0.6.0</jaxb2.version>
</properties>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment