Commit fd42f330 authored by seinturier's avatar seinturier

Using Juliac 2.0.1.

Setting version number to 0.3.1 before tagging.
parent 2e196b90
......@@ -21,8 +21,8 @@ Contact: Lionel.Seinturier@univ-lille1.fr
Author: Lionel Seinturier
============================================================================
Tinfi 0.4
---------
Tinfi 0.3.1
-----------
Tinfi is a runtime kernel for the SCA component model. Tinfi provides an
infrastructure for running Java applications which comply with version 1.0 of
......@@ -115,7 +115,7 @@ follows:
03 <plugin>
04 <groupId>org.objectweb.fractal.fractaladl.juliac.plugin</groupId>
05 <artifactId>maven-juliac-plugin</artifactId>
06 <version>2.0</version>
06 <version>2.0.1</version>
07 <executions>
08 <execution>
09 <id>juliac-compile</id>
......@@ -128,7 +128,7 @@ follows:
16 <configuration>
17 <opt>org.scorware.tinfi.juliac.FCOOCtrlSourceCodeGenerator</opt>
18 <srcs>src/main/java</srcs>
19 <mixins>org.scorware.tinfi:mixins:0.4:sources
19 <mixins>org.scorware.tinfi:mixins:0.3.1:sources
org.objectweb.fractal.julia:julia-mixins:2.5.2:sources</mixins>
20 <types>example.hw.HelloWorld</types>
21 </configuration>
......@@ -187,4 +187,4 @@ To run the conformance tests, type:
For any question concerning Tinfi, please contact
Lionel.Seinturier@univ-lille1.fr
Date of creation of this file: June 24, 2007.
Last modified: June 29, 2008.
Last modified: July 3, 2008.
Tinfi 0.4
---------
* move to Juliac 2.0
Tinfi 0.3.1
-----------
* move to Juliac 2.0.1
* bug fix in code generation with inner types (report by Fy)
* adding a tinfi-all artifact
......
......@@ -52,7 +52,7 @@
<arg value="--opt" />
<arg value="org.scorware.tinfi.juliac.FCOOCtrlSourceCodeGenerator" />
<arg value="--mixins" />
<arg value="${lib}/julia-mixins-2.5.2-sources.jar;${lib}/frascati-tinfi-mixins-0.4-SNAPSHOT-sources.jar" />
<arg value="${lib}/julia-mixins-2.5.2-sources.jar;${lib}/frascati-tinfi-mixins-0.3.1-sources.jar" />
<arg value="example.hw.HelloWorld" />
</java>
</target>
......
......@@ -14,7 +14,7 @@
<properties>
<julia.version>2.5.2</julia.version>
<juliac.version>2.0</juliac.version>
<juliac.version>2.0.1</juliac.version>
</properties>
<modules>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment