Commit 0576dae1 authored by Lionel Seinturier's avatar Lionel Seinturier

Use different versions of the libraries depending on the version of the JDK.

parent a77c1d20
......@@ -31,7 +31,7 @@
<dependency>
<groupId>org.ow2.fractal.julia</groupId>
<artifactId>julia-mixins-scala</artifactId>
<version>${julia.version}</version>
<version>${julia-mixins-scala.version}</version>
</dependency>
</dependencies>
......@@ -73,6 +73,29 @@
</plugins>
</build>
</profile>
<profile>
<id>jdk8</id>
<activation>
<jdk>[1.8,)</jdk>
</activation>
<properties>
<scala.version>2.12.1</scala.version>
<julia-mixins-scala.version>2.5.2.1</julia-mixins-scala.version>
</properties>
</profile>
<profile>
<id>jdk567</id>
<activation>
<jdk>(,1.8)</jdk>
</activation>
<properties>
<scala.version>2.9.1</scala.version>
<julia-mixins-scala.version>2.5.2</julia-mixins-scala.version>
</properties>
</profile>
</profiles>
</project>
......@@ -132,7 +132,6 @@
<julia.version>2.5.2</julia.version>
<koch.version>2.5.2.4</koch.version>
<juliac.version>2.7-SNAPSHOT</juliac.version>
<scala.version>2.9.1</scala.version>
</properties>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment