Commit 41716aad authored by Lionel Seinturier's avatar Lionel Seinturier

Fix used version numbers.

parent 8aac1609
......@@ -114,7 +114,6 @@
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-dependency-plugin</artifactId>
<version>2.0</version>
<executions>
<execution>
<id>copy-bundles</id>
......
......@@ -20,8 +20,10 @@
</dependency>
<dependency>
<groupId>org.apache.felix</groupId>
<groupId>org.osgi</groupId>
<artifactId>org.osgi.core</artifactId>
<version>${osgi.version}</version>
<scope>provided</scope>
</dependency>
</dependencies>
......@@ -30,7 +32,6 @@
<plugin>
<groupId>org.apache.felix</groupId>
<artifactId>maven-bundle-plugin</artifactId>
<version>2.0.1</version>
<executions>
<execution>
<id>bundle-bundle</id>
......
......@@ -14,8 +14,10 @@
<dependencies>
<dependency>
<groupId>org.apache.felix</groupId>
<groupId>org.osgi</groupId>
<artifactId>org.osgi.core</artifactId>
<version>${osgi.version}</version>
<scope>provided</scope>
</dependency>
</dependencies>
......@@ -24,7 +26,6 @@
<plugin>
<groupId>org.apache.felix</groupId>
<artifactId>maven-bundle-plugin</artifactId>
<version>2.0.1</version>
<executions>
<execution>
<id>bundle-bundle</id>
......
......@@ -19,15 +19,4 @@
<module>assembly</module>
</modules>
<dependencyManagement>
<dependencies>
<dependency>
<groupId>org.apache.felix</groupId>
<artifactId>org.osgi.core</artifactId>
<version>1.0.0</version>
<scope>provided</scope>
</dependency>
</dependencies>
</dependencyManagement>
</project>
......@@ -14,12 +14,28 @@
<name>Tinfi OSGi</name>
<packaging>pom</packaging>
<properties>
<osgi.version>4.2.0</osgi.version>
</properties>
<modules>
<module>opt</module>
<module>plugin</module>
<module>mixed</module>
</modules>
<build>
<pluginManagement>
<plugins>
<plugin>
<groupId>org.apache.felix</groupId>
<artifactId>maven-bundle-plugin</artifactId>
<version>3.3.0</version>
</plugin>
</plugins>
</pluginManagement>
</build>
<profiles>
<profile>
<id>tinfi:examples</id>
......
......@@ -242,6 +242,11 @@
<pluginManagement>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-dependency-plugin</artifactId>
<version>2.10</version>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-source-plugin</artifactId>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment