Commit b9bc1b21 authored by Philippe Merle's avatar Philippe Merle

Updated to use the Maven module 'bpel-parent'.

parent d571d83e
......@@ -29,7 +29,7 @@
<parent>
<groupId>org.ow2.frascati.examples</groupId>
<artifactId>parent</artifactId>
<artifactId>bpel-parent</artifactId>
<version>1.3-SNAPSHOT</version>
</parent>
......@@ -47,19 +47,7 @@
<method.params/>
</properties>
<build>
<plugins>
</plugins>
</build>
<dependencies>
<!-- Support for <sca:implementation.bpel> -->
<dependency>
<groupId>org.ow2.frascati</groupId>
<artifactId>frascati-implementation-bpel</artifactId>
<version>${frascati.version}</version>
</dependency>
<!-- Support for <frascati:binding.rest> -->
<dependency>
<groupId>org.ow2.frascati</groupId>
......@@ -73,45 +61,6 @@
<artifactId>frascati-binding-ws</artifactId>
<version>${frascati.version}</version>
</dependency>
<!-- For JUnit testing. -->
<dependency>
<groupId>org.ow2.frascati.examples.test</groupId>
<artifactId>frascati-test</artifactId>
<version>${frascati.version}</version>
<scope>test</scope>
</dependency>
</dependencies>
<profiles>
<!-- To execute an SCA composite with FraSCAti Explorer type 'mvn -Pexplorer'. -->
<profile>
<id>explorer</id>
<build>
<defaultGoal>exec:java</defaultGoal>
<plugins>
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>exec-maven-plugin</artifactId>
<configuration>
<systemProperties>
<systemProperty>
<!-- Warning, following is required by EasyViper: julia.cfg is the Julia config for EasyViper. -->
<key>julia.config</key>
<value>julia.cfg</value>
</systemProperty>
<systemProperty>
<!-- Following configures if EasyBPEL/Viper Explorer is launched at boot time. -->
<key>easybpel.explorer</key>
<value>true</value>
</systemProperty>
</systemProperties>
</configuration>
</plugin>
</plugins>
</build>
</profile>
</profiles>
</project>
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment