Commit 65ddaa57 authored by Johan Cwiklinski's avatar Johan Cwiklinski Committed by Johan Cwiklinski

Set PHP 5.6 as minimal required version

parent b4f97248
......@@ -17,9 +17,6 @@ script:
matrix:
include:
- php: 5.5
addons:
mariadb: 5.5
- php: 5.6
addons:
mariadb: 5.5
......
......@@ -31,7 +31,7 @@ It is distributed under the GNU GENERAL PUBLIC LICENSE Version 2 - please consul
* A web server (Apache, Nginx, IIS, etc.)
* MariaDB (or MySQL < 5.7)
* PHP 5.5 or higher
* PHP 5.6 or higher
* Mandatory PHP extensions:
- json
- mbstring
......
......@@ -11,7 +11,7 @@
"docs": "https://github.com/glpi-project/doc"
},
"require": {
"php": ">=5.5.0",
"php": ">=5.6.0",
"ext-mysqli": "*",
"ext-fileinfo": "*",
"ext-json": "*",
......@@ -42,7 +42,7 @@
},
"config": {
"platform": {
"php": "5.5.0"
"php": "5.6.0"
}
},
"scripts": {
......
......@@ -4,7 +4,7 @@
"Read more about it at https://getcomposer.org/doc/01-basic-usage.md#composer-lock-the-lock-file",
"This file is @generated automatically"
],
"content-hash": "5598ea765da0358f1c7fbf16df55d3f2",
"content-hash": "974047d145f6d4f5cfb09c9726894b1f",
"packages": [
{
"name": "iamcal/lib_autolink",
......@@ -1542,7 +1542,7 @@
"prefer-stable": false,
"prefer-lowest": false,
"platform": {
"php": ">=5.5.0",
"php": ">=5.6.0",
"ext-mysqli": "*",
"ext-fileinfo": "*",
"ext-json": "*",
......@@ -1553,6 +1553,6 @@
},
"platform-dev": [],
"platform-overrides": {
"php": "5.5.0"
"php": "5.6.0"
}
}
......@@ -38,7 +38,7 @@
// Current version of GLPI
define("GLPI_VERSION", "9.2");
define("GLPI_SCHEMA_VERSION", "9.2");
define('GLPI_MIN_PHP', '5.5.0');
define('GLPI_MIN_PHP', '5.6.0');
define('GLPI_YEAR', '2016');
define("GLPI_DEMO_MODE", "0");
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment