Commit ea1b0c66 authored by Cédric Anne's avatar Cédric Anne Committed by Johan Cwiklinski

Drop support of PHP 5.6

parent 99d8e8b2
......@@ -66,11 +66,6 @@ shared: &shared
name: sensiolabs/security-checker
command: vendor/bin/security-checker security:check
jobs:
"php5.6":
<<: *shared
docker:
- image: circleci/php:5.6-fpm-node-browsers
- image: circleci/mariadb:10.1
"php7.0":
<<: *shared
docker:
......@@ -97,7 +92,6 @@ workflows:
version: 2
tests_all:
jobs:
- php5.6
- php7.0
- php7.1
- php7.2
......
......@@ -27,12 +27,6 @@ script:
#note: default maria version is 5.5 for all main php versions list exept nightly
matrix:
include:
- php: 5.6
addons:
apt:
packages:
- ldap-utils
- slapd
- php: 7.0
addons:
mariadb: 10.2
......@@ -40,7 +34,6 @@ matrix:
packages:
- ldap-utils
- slapd
- php: 7.1
addons:
mariadb: 10.1
......@@ -48,7 +41,6 @@ matrix:
packages:
- ldap-utils
- slapd
- php: 7.2
addons:
apt:
......
......@@ -46,7 +46,7 @@ It is distributed under the GNU GENERAL PUBLIC LICENSE Version 2 - please consul
* A web server (Apache, Nginx, IIS, etc.)
* MariaDB >= 10.0 or MySQL >= 5.6
* PHP 5.6 or higher
* PHP 7.0.8 or higher
* Mandatory PHP extensions:
- json
- mbstring
......
......@@ -11,7 +11,7 @@
"docs": "https://github.com/glpi-project/doc"
},
"require": {
"php": ">=5.6.0",
"php": ">=7.0.8",
"ext-mysqli": "*",
"ext-fileinfo": "*",
"ext-json": "*",
......@@ -57,7 +57,7 @@
"config": {
"optimize-autoloader": true,
"platform": {
"php": "5.6.0"
"php": "7.0.8"
}
},
"scripts": {
......
This diff is collapsed.
......@@ -43,7 +43,7 @@ if (substr(GLPI_VERSION, -4) === '-dev') {
//for stable version
define("GLPI_SCHEMA_VERSION", '9.4');
}
define('GLPI_MIN_PHP', '5.6.0'); // Must also be changed in top of index.php
define('GLPI_MIN_PHP', '7.0.8'); // Must also be changed in top of index.php
define('GLPI_YEAR', '2018');
if (!defined('GLPI_DEMO_MODE')) {
define('GLPI_DEMO_MODE', '0');
......
......@@ -32,8 +32,8 @@
// Check PHP version not to have trouble
// Need to be the very fist step before any include
if (version_compare(PHP_VERSION, '5.6') < 0) {
die('PHP >= 5.6 required');
if (version_compare(PHP_VERSION, '7.0.8') < 0) {
die('PHP >= 7.0.8 required');
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment