Commit 0ded5ea1 authored by Nicolas Tachker's avatar Nicolas Tachker
Browse files

Update the maven plugin version to fix generated source problem ( NOT adding...

Update the maven plugin version to fix generated source problem ( NOT adding sources to artifacts with classifier as Maven only supports one classifier per artifact.)
Add a goal in java-doc plugin to generate the java doc jar for each module.
parent 777a69e9
......@@ -37,20 +37,21 @@
</modules>
<build>
<plugins>
<!-- Attach the source to the project -->
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-source-plugin</artifactId>
<!-- <version>2.1.2</version> -->
<version>${maven-source-plugin.version}</version>
<executions>
<execution>
<id>bind-sources</id>
<id>attach-sources</id>
<goals>
<goal>jar</goal>
<!-- <goal>jar-no-fork</goal> -->
<goal>jar-no-fork</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-release-plugin</artifactId>
......@@ -98,23 +99,25 @@
<id>doc</id>
<build>
<plugins>
<!-- Attach the javadoc to the project -->
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-javadoc-plugin</artifactId>
<version>2.8</version>
<version>${maven-javadoc-plugin.version}</version>
<configuration>
<show>private</show>
<nohelp>true</nohelp>
<links>
<link>http://download.oracle.com/javaee/7/api/</link>
</links>
<jarOutputDirectory>release/target</jarOutputDirectory>
</configuration>
<executions>
<execution>
<id>javadoc</id>
<phase>install</phase>
<id>attach-javadocs</id>
<phase>package</phase>
<goals>
<goal>jar</goal>
<goal>aggregate-jar</goal>
</goals>
</execution>
......@@ -122,6 +125,7 @@
</plugin>
</plugins>
</build>
<!-- reporting -->
<reporting>
<plugins>
......@@ -189,7 +193,7 @@
<felix.gogo.runtime.version>0.10.0</felix.gogo.runtime.version>
<felix.gogo.command.version>0.12.0</felix.gogo.command.version>
<felix.gogo.shell.version>0.10.0</felix.gogo.shell.version>
<maven.bundle.plugin.version>2.3.5</maven.bundle.plugin.version>
<maven.bundle.plugin.version>2.3.7</maven.bundle.plugin.version>
<!-- to prevent [WARNING] Using platform encoding -->
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<stomp.version>1.0</stomp.version>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment