Commit 2d2edb61 authored by Yadd's avatar Yadd
Browse files

Merge experimental branch (#960)

Also update version to 2.0
parent b7e249b4
......@@ -133,7 +133,7 @@
.\" ========================================================================
.\"
.IX Title "llng-fastcgi-server 1"
.TH llng-fastcgi-server 1 "2016-02-20" "perl v5.22.1" "User Contributed Perl Documentation"
.TH llng-fastcgi-server 1 "2016-03-08" "perl v5.22.1" "User Contributed Perl Documentation"
.\" For nroff, turn off justification. Always turn off hyphenation; it makes
.\" way too many mistakes in technical documents.
.if n .ad l
......
......@@ -5,7 +5,6 @@ use strict;
use warnings;
use POSIX;
use Getopt::Std;
use Lemonldap::NG::Handler::SharedConf;
our %opts;
my %_apps;
......@@ -75,9 +74,8 @@ my $app = sub {
};
# Hook for customFunctions initialization
use Lemonldap::NG::Handler::API::PSGI::Server;
$Lemonldap::NG::Handler::API::mode = 'PSGI::Server';
Lemonldap::NG::Handler::SharedConf->init();
use Lemonldap::NG::Handler::PSGI::API;
Lemonldap::NG::Handler::PSGI::API->init();
my $server = Plack::Runner->new();
$server->parse_options(
......
......@@ -10,7 +10,7 @@ build_requires:
configure_requires:
ExtUtils::MakeMaker: '0'
dynamic_config: 1
generated_by: 'ExtUtils::MakeMaker version 6.98, CPAN::Meta::Converter version 2.150005'
generated_by: 'ExtUtils::MakeMaker version 7.0401, CPAN::Meta::Converter version 2.150005'
license: open_source
meta-spec:
url: http://module-build.sourceforge.net/META-spec-v1.4.html
......@@ -44,5 +44,5 @@ requires:
Net::CIDR::Lite: '0'
SOAP::Lite: '0'
Storable: '0'
version: v1.9.1
version: v2.0.0
x_serialization_backend: 'CPAN::Meta::YAML version 0.012'
package Lemonldap::NG::Common;
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
use strict;
......
......@@ -15,7 +15,7 @@ use Lemonldap::NG::Common::Apache::Session::Serialize::JSON;
use Lemonldap::NG::Common::Apache::Session::Store;
use Lemonldap::NG::Common::Apache::Session::Lock;
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
sub _load {
my ( $backend, $func ) = @_;
......
......@@ -11,7 +11,7 @@ package Lemonldap::NG::Common::Apache::Session::Generate::SHA256;
use strict;
use Digest::SHA qw(sha256 sha256_hex sha256_base64);
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
sub generate {
my $session = shift;
......
......@@ -8,7 +8,7 @@ package Lemonldap::NG::Common::Apache::Session::SOAP;
use strict;
use SOAP::Lite;
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
#parameter proxy Url of SOAP service
#parameter proxyOptions SOAP::Lite options
......
......@@ -3,7 +3,7 @@ package Lemonldap::NG::Common::Apache::Session::Serialize::JSON;
use strict;
use JSON;
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
sub serialize {
my $session = shift;
......
package Lemonldap::NG::Common::Apache::Session::Store;
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
sub new {
my $class = shift;
......
......@@ -17,7 +17,7 @@ use Net::CIDR::Lite;
#parameter syslog Indicates syslog facility for logging user actions
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
our $_SUPER;
our @ISA;
......
......@@ -11,7 +11,7 @@ use SOAP::Transport::HTTP;
use base qw(SOAP::Transport::HTTP::Server);
use bytes;
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
## @method protected void DESTROY()
# Call SOAP::Trace::objects().
......
......@@ -7,7 +7,7 @@ package Lemonldap::NG::Common::CGI::SOAPService;
require SOAP::Lite;
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
## @cmethod Lemonldap::NG::Common::CGI::SOAPService new(object obj,string @func)
# Constructor
......
......@@ -6,7 +6,7 @@
package Lemonldap::NG::Common::Captcha;
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
use strict;
use Lemonldap::NG::Common::Session;
......
......@@ -23,7 +23,7 @@ use Config::IniFiles;
#inherits Lemonldap::NG::Common::Conf::SOAP
#inherits Lemonldap::NG::Common::Conf::LDAP
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
our $msg = '';
our $iniObj;
......
......@@ -5,7 +5,7 @@ use utf8;
use JSON;
use Lemonldap::NG::Common::Conf::_DBI;
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
our @ISA = qw(Lemonldap::NG::Common::Conf::_DBI);
sub store {
......
......@@ -5,7 +5,7 @@ use strict;
use Exporter 'import';
use base qw(Exporter);
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
# CONSTANTS
......
......@@ -5,7 +5,7 @@ use utf8;
use Lemonldap::NG::Common::Conf::Serializer;
use Lemonldap::NG::Common::Conf::_DBI;
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
our @ISA = qw(Lemonldap::NG::Common::Conf::_DBI);
sub store {
......
# This file is generated by Lemonldap::NG::Manager::Build. Don't modify it by hand
package Lemonldap::NG::Common::Conf::DefaultValues;
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
sub defaultValues {
return {
......
......@@ -5,7 +5,7 @@ use Lemonldap::NG::Common::Conf::Constants; #inherits
use JSON;
use Encode;
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
our $initDone;
sub Lemonldap::NG::Common::Conf::_lock {
......
......@@ -12,7 +12,7 @@ use Lemonldap::NG::Common::Conf::Constants; #inherits
use Lemonldap::NG::Common::Conf::Serializer;
use Encode;
our $VERSION = '1.9.1';
our $VERSION = '2.0.0';
BEGIN {
*Lemonldap::NG::Common::Conf::ldap = \&ldap;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment