Allow disabling class file version check in class reader to better allow ASM...

Allow disabling class file version check in class reader to better allow ASM users to work with EA releases of the JVM after version numbers are increased.

Makes a formerly package-private constructor accessible. As many ASM users shade ASM, it is already easily possible to use this constructor by creating a subclass in the org.objectweb.asm package that invokes this constructor with the appropriate access rights but it would be nicer to get a more official way to access the constructor.
2 jobs for master in 1 minute and 41 seconds (queued for 3 seconds)
Name Stage Failure
failed
build Test There is an unknown failure, please try again

* Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
See https://docs.gradle.org/4.6/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 1m 31s
22 actionable tasks: 22 executed
ERROR: Job failed: exit code 1