Commit dedba43e authored by IKEDA Soji's avatar IKEDA Soji

Test: t/pod-syntax.t: Test::Pod 1.40 mistakenly complains about the construct...

Test: t/pod-syntax.t: Test::Pod 1.40 mistakenly complains about the construct L<text|url>. Use 1.41 or later.
parent 55749349
...@@ -306,7 +306,7 @@ on 'test' => sub { ...@@ -306,7 +306,7 @@ on 'test' => sub {
requires 'Test::Compile'; requires 'Test::Compile';
requires 'Test::Harness'; requires 'Test::Harness';
requires 'Test::More'; requires 'Test::More';
requires 'Test::Pod'; requires 'Test::Pod', '>= 1.41';
}; };
on 'develop' => sub { on 'develop' => sub {
......
...@@ -7,14 +7,19 @@ use warnings; ...@@ -7,14 +7,19 @@ use warnings;
use English qw(-no_match_vars); use English qw(-no_match_vars);
use Test::More; use Test::More;
my $test_pod_ok;
BEGIN { BEGIN {
eval 'use Test::Pod'; # Test::Pod 1.40 mistakenly complains about the construct L<text|url>.
eval 'use Test::Pod 1.41';
$test_pod_ok = 1 unless $EVAL_ERROR;
}
unless ($test_pod_ok) {
plan(skip_all => 'Test::Pod 1.41 or later required');
} else {
my @files = (
all_pod_files('src'), glob('doc/*.pod'),
glob('doc/*.podin'), glob('doc/*.podpl')
);
all_pod_files_ok(@files);
} }
plan(skip_all => 'Test::Pod required') unless $Test::Pod::VERSION;
my @files = (
all_pod_files('src'), glob('doc/*.pod'),
glob('doc/*.podin'), glob('doc/*.podpl')
);
all_pod_files_ok(@files);
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment