Commit 9809f8d1 authored by Yann Mombrun's avatar Yann Mombrun
Browse files

Fixing numpy installation

parent 32ee1449
......@@ -101,7 +101,7 @@ sudo apt-get $aptGetFlags install libopencv-dev libmicrohttpd-dev libjsoncpp-dev
if [[ -n "$extendSudo" ]] ; then sudo -v ; fi
# Various lib needed for Visor
if [[ -n "$includeOnTheFlyClassifier" ]] ; then
sudo apt-get $aptGetFlags install build-essential cmake libopencv-dev libgoogle-glog-dev libbz2-dev sed gawk gfortran
sudo apt-get $aptGetFlags install build-essential cmake libopencv-dev libgoogle-glog-dev libbz2-dev sed gawk gfortran python-numpy
if [[ -n "$extendSudo" ]] ; then sudo -v ; fi
sudo apt-get $aptGetFlags install libprotobuf-dev protobuf-compiler libsnappy1 libsnappy-dev libleveldb1 libleveldb-dev
if [[ -n "$extendSudo" ]] ; then sudo -v ; fi
......@@ -116,7 +116,7 @@ if [[ -n "$extendSudo" ]] ; then sudo -v ; fi
sudo pip $pipFlags install PIL --allow-external PIL --allow-unverified PIL
# A few more libs needed for cpuvisor and imsearch-tools to be installed through PIP
if [[ -n "$includeOnTheFlyClassifier" ]] ; then
sudo pip $pipFlags install "numpy>=1.8.0" "matplotlib>=1.3.1" "pyzmq>=14.3.1" "gevent>=1.0.1" "protobuf>=2.5.0" scipy flask zmq gevent-zeromq
sudo pip $pipFlags install "numpy>=1.8.0" "matplotlib>=1.3.1" "pyzmq>=14.3.1" "gevent>=1.0.1" "protobuf>=2.5.0" scipy flask gevent-zeromq
fi
echo "PIP based installation finished successfully"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment