Commit 21856ea3 authored by Xavier Guimard's avatar Xavier Guimard

Update dependecies (#595)

parent 56337e60
......@@ -42,7 +42,6 @@ Build-Depends-Indep: libapache-session-perl,
libtest-pod-perl,
libunicode-string-perl,
liburi-perl,
libhttp-message-perl,
libwww-perl,
libxml-libxml-perl,
libxml-libxslt-perl,
......@@ -120,7 +119,7 @@ Depends: ${misc:Depends},
liblemonldap-ng-handler-perl (= ${binary:Version}),
libplack-perl,
nginx-extras | nginx
Recommends: libhttp-parser-xs-perl,
Recommends: libhttp-parser-xs-perl
Suggests: nginx-extras
Section: web
Description: Lemonldap::NG FastCGI server
......@@ -165,11 +164,9 @@ Depends: ${misc:Depends},
libmouse-perl,
liburi-perl,
libwww-perl
Recommends: libhttp-message-perl,
liblwp-protocol-https-perl
Recommends: liblwp-protocol-https-perl
Suggests: libcache-memcached-perl,
libdigest-hmac-perl,
liblemonldap-ng-portal-perl,
libsoap-lite-perl
Description: Lemonldap::NG handler common libraries
Lemonldap::NG is a complete Web-SSO system that can run with reverse-proxies
......@@ -205,19 +202,19 @@ Depends: ${misc:Depends},
libcrypt-openssl-rsa-perl,
libcrypt-openssl-x509-perl,
libcrypt-rijndael-perl,
libdbi-perl,
libdigest-sha-perl,
libhtml-template-perl,
libjson-perl,
libmouse-perl,
libnet-cidr-lite-perl,
libplack-perl,
libsoap-lite-perl
liburi-perl
Recommends: libapache-session-browseable-perl,
libhtml-template-perl,
libhttp-message-perl,
libnet-ldap-perl,
liblwp-protocol-https-perl,
libxml-libxml-perl,
libxml-simple-perl
libdbi-perl,
liblwp-protocol-https-perl
Suggests: libnet-ldap-perl,
libsoap-lite-perl,
libxml-libxml-perl,
libxml-simple-perl
Conflicts: liblemonldap-ng-cli-perl
Description: Lemonldap::NG common files
Lemonldap::NG is a complete Web-SSO system that can run with reverse-proxies
......@@ -239,8 +236,6 @@ Depends: ${misc:Depends},
${perl:Depends},
libconvert-pem-perl,
libcrypt-openssl-rsa-perl,
libhtml-template-perl,
libjson-perl,
liblemonldap-ng-common-perl (= ${binary:Version}),
liblemonldap-ng-handler-perl (= ${binary:Version}),
libmouse-perl,
......@@ -274,18 +269,15 @@ Architecture: all
Depends: ${misc:Depends},
${perl:Depends},
apache2 | nginx | httpd-cgi,
libcgi-pm-perl,
libclone-perl,
libhtml-template-perl,
liblemonldap-ng-common-perl (= ${binary:Version}),
libmime-lite-perl,
libcrypt-openssl-bignum-perl,
libnet-ldap-perl,
libregexp-assemble-perl,
libstring-random-perl,
libunicode-string-perl,
liburi-perl
Recommends: libnet-facebook-oauth2-perl | libnet-openid-consumer-perl | libnet-openid-server-perl | liblasso-perl | libnet-oauth-perl | libauthcas-perl | libweb-id-perl,
liblemonldap-ng-handler-perl (= ${binary:Version}),
libregexp-assemble-perl
Recommends: libcrypt-openssl-bignum-perl,
libmime-lite-perl,
libnet-ldap-perl,
libnet-facebook-oauth2-perl | libnet-openid-consumer-perl | libnet-openid-server-perl | liblasso-perl | libnet-oauth-perl | libauthcas-perl | libweb-id-perl,
libstring-random-perl,
libunicode-string-perl,
libwww-perl
Suggests: libauthcas-perl,
libauthen-captcha-perl,
......@@ -301,11 +293,7 @@ Suggests: libauthcas-perl,
libnet-oauth-perl,
libsoap-lite-perl,
libweb-id-perl,
libhttp-message-perl,
liblwp-protocol-https-perl,
libxml-libxml-perl,
libxml-libxslt-perl,
libxml-simple-perl,
slapd
Pre-Depends: debconf
Description: Lemonldap::NG authentication portal part
......
......@@ -21,10 +21,10 @@ no_index:
- inc
recommends:
Apache::Session::Browseable: '0'
HTML::Template: '0'
HTTP::Message: '0'
JSON: '0'
DBI: '0'
LWP::Protocol::https: '0'
Net::LDAP: '0'
SOAP::Lite: '0'
requires:
Apache::Session: '0'
Cache::Cache: '0'
......@@ -34,11 +34,10 @@ requires:
Crypt::OpenSSL::X509: '0'
Crypt::Rijndael: '0'
Digest::SHA: '0'
File::Basename: '0'
HTML::Template: '0'
JSON: '0'
Mouse: '0'
Net::CIDR::Lite: '0'
Plack: '0'
SOAP::Lite: '0'
URI: '0'
version: v2.0.0
x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
......@@ -24,34 +24,33 @@ WriteMakefile(
VERSION_FROM => 'lib/Lemonldap/NG/Common.pm', # finds $VERSION
LICENSE => 'gpl',
BUILD_REQUIRES => {
'IO::String' => 0,
'Net::LDAP' => 0,
'Test::Pod' => 1.00,
'IO::String' => 0,
'Net::LDAP' => 0,
'Test::Pod' => 1.00,
},
META_MERGE => {
'recommends' => {
'Apache::Session::Browseable' => 0,
'HTML::Template' => 0,
'HTTP::Message' => 0,
'JSON' => 0,
'DBI' => 0,
'Net::LDAP' => 0,
'SOAP::Lite' => 0,
'LWP::Protocol::https' => 0,
},
},
PREREQ_PM => {
'Apache::Session' => 0,
'Cache::Cache' => 0,
'Config::IniFiles' => 0,
'Crypt::OpenSSL::Bignum' => 0,
'Crypt::OpenSSL::RSA' => 0,
'Crypt::OpenSSL::X509' => 0,
'Crypt::Rijndael' => 0,
'Config::IniFiles' => 0,
'Digest::SHA' => 0,
'File::Basename' => 0,
'HTML::Template' => 0,
'JSON' => 0,
'Mouse' => 0,
'Plack' => 0,
'Net::CIDR::Lite' => 0,
'SOAP::Lite' => 0,
'URI' => 0,
}, # e.g., Module::Name => 1.1
#EXE_FILES => [ 'scripts/convertConfig', ],
(
......
......@@ -5,10 +5,7 @@ author:
build_requires:
Cwd: '0'
Digest::HMAC_SHA1: '0'
File::Basename: '0'
HTTP::Message: '0'
IO::Pipe: '0'
SOAP::Lite: '0'
Test::MockObject: '0'
Test::Pod: '0'
configure_requires:
......@@ -28,12 +25,9 @@ recommends:
Cache::Memcached: '0'
Digest::HMAC_SHA1: '0'
HTTP::Message: '0'
LWP::Protocol::https: '0'
SOAP::Lite: '0'
requires:
Apache::Session::Generate::MD5: '0'
CGI: '3.08'
LWP: '0'
LWP::UserAgent: '0'
Lemonldap::NG::Common: v1.9.99
Mouse: '0'
URI: '0'
......
......@@ -10,30 +10,24 @@ WriteMakefile(
PMLIBDIRS => ['lib'],
BUILD_REQUIRES => {
'Digest::HMAC_SHA1' => 0,
'HTTP::Message' => 0,
'IO::Pipe' => 0,
'SOAP::Lite' => 0,
'Test::MockObject' => 0,
'Test::Pod' => 0,
'File::Basename' => 0,
'Cwd' => 0,
},
META_MERGE => {
'recommends' => {
'Cache::Memcached' => 0,
'Digest::HMAC_SHA1' => 0,
'HTTP::Message' => 0,
'LWP::Protocol::https' => 0,
'SOAP::Lite' => 0,
'Cache::Memcached' => 0,
'Digest::HMAC_SHA1' => 0,
'HTTP::Message' => 0,
'SOAP::Lite' => 0,
},
},
PREREQ_PM => {
'Apache::Session::Generate::MD5' => 0,
'CGI' => 3.08,
'Lemonldap::NG::Common' => '1.9.99',
'LWP' => 0,
'Mouse' => 0,
'URI' => 0,
'Lemonldap::NG::Common' => '1.9.99',
'LWP::UserAgent' => 0,
'Mouse' => 0,
'URI' => 0,
}, # e.g., Module::Name => 1.1
(
$] >= 5.005
......
......@@ -19,15 +19,13 @@ no_index:
directory:
- t
- inc
recommends:
LWP::Protocol::https: '0'
requires:
Convert::PEM: '0'
Crypt::OpenSSL::RSA: '0'
HTML::Template: '0'
JSON: '0'
LWP: '0'
LWP::UserAgent: '0'
Lemonldap::NG::Common: v1.9.99
Lemonldap::NG::Handler: v1.9.99
URI: '0'
version: v2.0.0
x_LWP::Protocol::https: 0
x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
......@@ -12,16 +12,17 @@ WriteMakefile(
'Regexp::Common' => 0,
'Test::Pod' => 1.00,
},
META_MERGE => { 'LWP::Protocol::https' => 0, },
PREREQ_PM => {
META_MERGE => {
recommends => {
'LWP::Protocol::https' => 0,
}
},
PREREQ_PM => {
'Convert::PEM' => 0,
'Crypt::OpenSSL::RSA' => 0,
'HTML::Template' => 0,
'JSON' => 0,
'Lemonldap::NG::Common' => '1.9.99',
'Lemonldap::NG::Handler' => '1.9.99',
'LWP' => 0,
'URI' => 0,
'LWP::UserAgent' => 0,
}, # e.g., Module::Name => 1.1
(
$] >= 5.005
......
......@@ -38,20 +38,17 @@ recommends:
Lasso: v2.3.0
MIME::Lite: '0'
Net::Facebook::Oauth2: '0'
Net::LDAP: '0.38'
Net::OAuth: '0'
Net::OpenID::Consumer: '0'
Net::OpenID::Server: '0'
SOAP::Lite: '0'
String::Random: '0'
URI: '0'
Unicode::String: '0'
Web::ID: '0'
requires:
Clone: '0'
HTML::Template: '0'
JSON: '0'
Lemonldap::NG::Handler: v1.9.99
Net::LDAP: '0.38'
Regexp::Assemble: '0'
Unicode::String: '0'
version: v2.0.0
x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
......@@ -20,12 +20,13 @@ WriteMakefile(
'LWP::Protocol::https' => 0,
'MIME::Lite' => 0,
'Net::Facebook::Oauth2' => 0,
'Net::LDAP' => 0.38,
'Net::OAuth' => 0,
'Net::OpenID::Consumer' => 0,
'Net::OpenID::Server' => 0,
'SOAP::Lite' => 0,
'String::Random' => 0,
'URI' => 0,
'Unicode::String' => 0,
'Web::ID' => 0,
},
},
......@@ -43,12 +44,8 @@ WriteMakefile(
},
PREREQ_PM => {
'Clone' => 0,
'HTML::Template' => 0,
'JSON' => 0,
'Lemonldap::NG::Handler' => '1.9.99',
'Net::LDAP' => 0.38,
'Regexp::Assemble' => 0,
'Unicode::String' => 0,
},
(
$] >= 5.005
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment