Commit 3401089e authored by Christophe Maudoux's avatar Christophe Maudoux 🐛

Modify init condition - History is required (#1506)

parent e41a241d
......@@ -12,7 +12,15 @@ extends 'Lemonldap::NG::Portal::Main::Plugin';
use constant afterData => 'run';
sub init {1}
sub init {
my ($self) = @_;
unless ( $self->conf->{loginHistoryEnabled} ) {
$self->logger->error(
'"History" plugin is required for "BruteForceProtection" plugin');
return 0;
}
return 1;
}
# RUNNING METHOD
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment