Commit 8c073cc0 authored by Xavier Guimard's avatar Xavier Guimard

LEMONLDAP::NG : little corrections issued from CPAN test

parent 6966d209
Revision history for Perl extension Lemonldap::NG::Handler. Revision history for Perl extension Lemonldap::NG::Handler.
0.88 Fri jun 6 14:58:41 2008
- Status.pm test failed in jail
0.87 Tue may 9 22:32:44 2008 0.87 Tue may 9 22:32:44 2008
- Remove Apache2::compat dependency - Remove Apache2::compat dependency
- New status module - New status module
......
...@@ -2,7 +2,7 @@ package Lemonldap::NG::Handler; ...@@ -2,7 +2,7 @@ package Lemonldap::NG::Handler;
print STDERR print STDERR
"See Lemonldap::NG::Handler(3) to know which Lemonldap::NG::Handler::* module to use."; "See Lemonldap::NG::Handler(3) to know which Lemonldap::NG::Handler::* module to use.";
our $VERSION = "0.87"; our $VERSION = "0.88";
1; 1;
......
...@@ -8,7 +8,7 @@ use Safe; ...@@ -8,7 +8,7 @@ use Safe;
require Data::Dumper; require Data::Dumper;
require POSIX; require POSIX;
our $VERSION = '0.87'; our $VERSION = '0.88';
our %EXPORT_TAGS; our %EXPORT_TAGS;
......
...@@ -5,13 +5,21 @@ ...@@ -5,13 +5,21 @@
# change 'tests => 1' to 'tests => last_test_to_print'; # change 'tests => 1' to 'tests => last_test_to_print';
use Test::More tests => 9; BEGIN {
our $home=0;
$home++ if($ENV{DEBFULLNAME} eq 'Xavier Guimard');
}
use Test::More tests => 1 + 8*$home;
BEGIN { use_ok( 'Lemonldap::NG::Handler::Simple', ':all' ) } BEGIN { use_ok( 'Lemonldap::NG::Handler::Simple', ':all' ) }
######################### #########################
# Insert your test code below, the Test::More module is use()ed here so read # Insert your test code below, the Test::More module is use()ed here so read
# its man page ( perldoc Test::More ) for help writing this test script. # its man page ( perldoc Test::More ) for help writing this test script.
exit unless($home);
my $h; my $h;
$h = bless {}, 'Lemonldap::NG::Handler::Simple'; $h = bless {}, 'Lemonldap::NG::Handler::Simple';
ok( ok(
......
...@@ -2,7 +2,7 @@ package Lemonldap::NG::Portal; ...@@ -2,7 +2,7 @@ package Lemonldap::NG::Portal;
print STDERR print STDERR
"See Lemonldap::NG::Portal(3) to know which Lemonldap::NG::Portal::* module to use."; "See Lemonldap::NG::Portal(3) to know which Lemonldap::NG::Portal::* module to use.";
our $VERSION = "0.83"; our $VERSION = "0.84";
1; 1;
......
...@@ -13,7 +13,7 @@ use CGI::Cookie; ...@@ -13,7 +13,7 @@ use CGI::Cookie;
require POSIX; require POSIX;
use Lemonldap::NG::Portal::_i18n; use Lemonldap::NG::Portal::_i18n;
our $VERSION = '0.83'; our $VERSION = '0.84';
our @ISA = qw(CGI Exporter); our @ISA = qw(CGI Exporter);
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment