Commit bb9e0ef8 authored by Xavier Bachelot's avatar Xavier Bachelot

Drop EL6 support, perl in EL6 is too old for the code base anyway

parent d5827c6f
...@@ -98,12 +98,9 @@ BuildRequires: perl(Digest::HMAC_SHA1) ...@@ -98,12 +98,9 @@ BuildRequires: perl(Digest::HMAC_SHA1)
BuildRequires: perl(Digest::MD5) BuildRequires: perl(Digest::MD5)
BuildRequires: perl(Digest::SHA) BuildRequires: perl(Digest::SHA)
BuildRequires: perl(Email::Date::Format) BuildRequires: perl(Email::Date::Format)
# Not available for EL6
%if ! 0%{?el6}
BuildRequires: perl(Email::Sender) BuildRequires: perl(Email::Sender)
BuildRequires: perl(Email::Sender::Simple) BuildRequires: perl(Email::Sender::Simple)
BuildRequires: perl(Email::Sender::Transport::SMTP) BuildRequires: perl(Email::Sender::Transport::SMTP)
%endif
BuildRequires: perl(Encode) BuildRequires: perl(Encode)
BuildRequires: perl(English) BuildRequires: perl(English)
BuildRequires: perl(Env) BuildRequires: perl(Env)
...@@ -139,9 +136,7 @@ BuildRequires: perl(Mouse) ...@@ -139,9 +136,7 @@ BuildRequires: perl(Mouse)
BuildRequires: perl(Net::LDAP) BuildRequires: perl(Net::LDAP)
BuildRequires: perl(Net::LDAP::Extension::SetPassword) BuildRequires: perl(Net::LDAP::Extension::SetPassword)
BuildRequires: perl(Net::LDAP::Util) BuildRequires: perl(Net::LDAP::Util)
%if 0%{?fedora} || 0%{?rhel} >=7
BuildRequires: perl(Net::OpenID::Server) BuildRequires: perl(Net::OpenID::Server)
%endif
BuildRequires: perl(Plack) BuildRequires: perl(Plack)
BuildRequires: perl(Plack::Handler::CGI) BuildRequires: perl(Plack::Handler::CGI)
BuildRequires: perl(Plack::Handler::FCGI) BuildRequires: perl(Plack::Handler::FCGI)
...@@ -179,9 +174,7 @@ BuildRequires: perl(XML::LibXML) ...@@ -179,9 +174,7 @@ BuildRequires: perl(XML::LibXML)
BuildRequires: perl(XML::LibXSLT) BuildRequires: perl(XML::LibXSLT)
BuildRequires: perl(XML::Simple) BuildRequires: perl(XML::Simple)
BuildRequires: perl(YAML) BuildRequires: perl(YAML)
%if 0%{?fedora} || 0%{?rhel} >= 7
BuildRequires: systemd BuildRequires: systemd
%endif
Requires: lemonldap-ng-conf = %{version}-%{release} Requires: lemonldap-ng-conf = %{version}-%{release}
Requires: lemonldap-ng-doc = %{version}-%{release} Requires: lemonldap-ng-doc = %{version}-%{release}
...@@ -191,11 +184,6 @@ Requires: lemonldap-ng-portal = %{version}-%{release} ...@@ -191,11 +184,6 @@ Requires: lemonldap-ng-portal = %{version}-%{release}
Requires: lemonldap-ng-test = %{version}-%{release} Requires: lemonldap-ng-test = %{version}-%{release}
# Setup requires filtering # Setup requires filtering
%if 0%{?rhel} == 6
%filter_from_requires /perl(lasso/d; /perl(Net::OpenID/d; /perl(Web::ID/d; /perl(XML::LibXML/d; /perl(XML::LibXSLT/d; /perl(Sentry::Raven/d;
%filter_setup
%endif
%if 0%{?rhel} >= 7 %if 0%{?rhel} >= 7
%{?perl_default_filter} %{?perl_default_filter}
%global __requires_exclude perl\\(lasso|perl\\(Web::ID|perl\\(XML::LibXML|perl\\(XML::LibXSLT|perl\\(Sentry::Raven %global __requires_exclude perl\\(lasso|perl\\(Web::ID|perl\\(XML::LibXML|perl\\(XML::LibXSLT|perl\\(Sentry::Raven
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment