Commit edfb4aa3 authored by Xavier Guimard's avatar Xavier Guimard

LEMONLDAP::NG : update module versions and changelogs

parent 6959f1c2
lemonldap-ng (0.9.1) unstable; urgency=low
* logout bug : logout_sso target was not running (Closes: #308856)
* javascript update : the manager was not running with MSIE7 (Closes:
#308775)
* Debian corrections issued from lintian (full)
* 2 Net::LDAP password policy controls in the portal:
- account locked
- password expired
-- Xavier Guimard <x.guimard@free.fr> Mon, 07 Apr 2008 11:13:06 +0200
lemonldap-ng (0.9) unstable; urgency=low
* Liberty Alliance module issued of the FederID project is now included.
......
lemonldap-ng (0.9-0) unstable; urgency=low
lemonldap-ng (0.9.1-0) unstable; urgency=low
* Local build
-- Xavier Guimard <x.guimard@free.fr> Mon, 22 Oct 2007 21:34:23 +0200
-- Xavier Guimard <x.guimard@free.fr> Mon, 07 Apr 2008 11:00:37 +0200
Revision history for Perl extension Lemonldap::NG::Handler.
0.86 Mon apr 7 14:52:30 2008
- logout bug : logout_sso target was not running (Closes: #308856 /
forge.objectweb.org)
0.85 Fri feb 8 17:50:25 2008
- local overload was not taken in account
- little bugs in redirections
......
......@@ -2,7 +2,7 @@ package Lemonldap::NG::Handler;
print STDERR
"See Lemonldap::NG::Handler(3) to know which Lemonldap::NG::Handler::* module to use.";
our $VERSION = "0.85";
our $VERSION = "0.86";
1;
......
......@@ -5,7 +5,7 @@ use strict;
use Lemonldap::NG::Handler::Simple qw(:apache :headers :log);
use LWP::UserAgent;
our $VERSION = '0.3';
our $VERSION = '0.31';
##########################################
# COMPATIBILITY WITH APACHE AND APACHE 2 #
......
......@@ -7,33 +7,13 @@ use Exporter 'import';
use Safe;
require POSIX;
our $VERSION = '0.85';
our %EXPORT_TAGS = (
localStorage => [qw( $localStorage $localStorageOptions $refLocalStorage )],
globalStorage => [qw( $globalStorage $globalStorageOptions )],
locationRules => [
qw(
$locationCondition $defaultCondition $locationCount
$locationRegexp $apacheRequest $datas $safe $portal
)
],
import => [qw( import @EXPORT_OK @EXPORT %EXPORT_TAGS )],
headers => [
qw(
$forgeHeaders lmHeaderIn lmSetHeaderIn lmHeaderOut
lmSetHeaderOut lmSetErrHeaderOut $cookieName $cookieSecured
$https $port
)
],
log => [qw( lmLog )],
traces => [qw( $whatToTrace )],
apache => [qw( MP OK REDIRECT FORBIDDEN DONE DECLINED SERVER_ERROR )],
);
our $VERSION = '0.86';
our %EXPORT_TAGS;
our @EXPORT_OK = ();
our @EXPORT_OK;
our @EXPORT = ();
our @EXPORT;
# Shared variables
our (
......@@ -51,10 +31,28 @@ our (
##########################################
BEGIN {
push( @EXPORT_OK, @{ $EXPORT_TAGS{$_} } )
foreach (
qw( localStorage globalStorage locationRules import headers traces apache )
);
%EXPORT_TAGS = (
localStorage => [qw( $localStorage $localStorageOptions $refLocalStorage )],
globalStorage => [qw( $globalStorage $globalStorageOptions )],
locationRules => [
qw(
$locationCondition $defaultCondition $locationCount
$locationRegexp $apacheRequest $datas $safe $portal
)
],
import => [qw( import @EXPORT_OK @EXPORT %EXPORT_TAGS )],
headers => [
qw(
$forgeHeaders lmHeaderIn lmSetHeaderIn lmHeaderOut
lmSetHeaderOut lmSetErrHeaderOut $cookieName $cookieSecured
$https $port
)
],
log => [qw( lmLog )],
traces => [qw( $whatToTrace )],
apache => [qw( MP OK REDIRECT FORBIDDEN DONE DECLINED SERVER_ERROR )],
);
push( @EXPORT_OK, @{ $EXPORT_TAGS{$_} } ) foreach ( keys %EXPORT_TAGS );
$EXPORT_TAGS{all} = \@EXPORT_OK;
if ( exists $ENV{MOD_PERL} ) {
if ( $ENV{MOD_PERL_API_VERSION} and $ENV{MOD_PERL_API_VERSION} >= 2 ) {
......@@ -121,17 +119,13 @@ BEGIN {
*logout = ( MP() == 2 ) ? \&logout_mp2 : \&logout_mp1;
}
sub handler_mp1 ($$) { shift->run(@_) }
sub handler_mp1 ($$) { shift->run(@_); }
sub handler_mp2 : method {
shift->run(@_);
}
sub handler_mp2 : method { shift->run(@_); }
sub logout_mp1 ($$) { shift->unlog(@_) }
sub logout_mp1 ($$) { shift->unlog(@_); }
sub logout_mp2 : method {
shift->unlog(@_);
}
sub logout_mp2 : method { shift->unlog(@_); }
sub lmLog {
my ( $class, $mess, $level ) = @_;
......@@ -512,8 +506,7 @@ sub run ($$) {
( $class, $apacheRequest ) = @_;
return DECLINED unless ( $apacheRequest->is_initial_req );
my $uri = $apacheRequest->uri
. ( $apacheRequest->args ? "?" . $apacheRequest->args : "" );
my $uri = $apacheRequest->uri . ( $apacheRequest->args ? "?" . $apacheRequest->args : "" );
# AUTHENTICATION
# I - recover the cookie
......
Revision history for Perl extension Lemonldap::NG::Manager.
0.83 Fri feb 8 17:45:34 2008
0.84 Mon apr 7 14:55:45 2008
- Javascript update (Closes: #308775 / forge.objectweb.org)
0.83 Fri feb 8 17:45:34 2008
- bugs in SOAP server
- sessions timeout is now included in the manager
0.82 Sat jul 21 15:21:32 2007
0.82 Sat jul 21 15:21:32 2007
- TLS support in LDAP
- Help for new logout system
0.8 Sat jun 23 21:54:27 2007
- New feature: syntax errors are now displayed in the manager interface
- New feature: syntax errors are now displayed in the manager
interface
0.72 Tue jun 20 22:00:15 2007
- Javascript rewrite
......@@ -24,7 +28,8 @@ Revision history for Perl extension Lemonldap::NG::Manager.
- Little bug correction: '-' is authorized in domain names
0.65 Sun May 6 16:15:49 2007
- SOAP: HTTP basic authentication and little bug correction in 'sessions'
- SOAP: HTTP basic authentication and little bug correction in
'sessions'
mode
- More tests in conf
......
......@@ -17,7 +17,7 @@ use MIME::Base64;
our @ISA = qw(Lemonldap::NG::Manager::Base);
our $VERSION = '0.83';
our $VERSION = '0.84';
sub new {
my ( $class, $args ) = @_;
......
......@@ -5,7 +5,7 @@ use DBI;
use MIME::Base64;
use Lemonldap::NG::Manager::Conf::Constants;
our $VERSION = 0.16;
our $VERSION = 0.17;
BEGIN {
*Lemonldap::NG::Manager::Conf::dbh = \&dbh;
......
Revision history for Perl extension Lemonldap::NG::Portal.
0.81 Wed Feb 8 17:44:46 2008
0.82 Mon Apr 7 15:01:02 2008
- 2 Net::LDAP password policy controls in the portal:
* account locked
* password expired
0.81 Wed Feb 8 17:44:46 2008
- Ldap groups can now be available in $groups
- Bug in AuthSSL
......
......@@ -2,7 +2,7 @@ package Lemonldap::NG::Portal;
print STDERR
"See Lemonldap::NG::Portal(3) to know which Lemonldap::NG::Portal::* module to use.";
our $VERSION = "0.81";
our $VERSION = "0.82";
1;
......
......@@ -13,7 +13,7 @@ use CGI::Cookie;
require POSIX;
use Lemonldap::NG::Portal::_i18n;
our $VERSION = '0.77';
our $VERSION = '0.78';
our @ISA = qw(CGI Exporter);
......
......@@ -2,7 +2,7 @@ package Lemonldap::NG::Portal::_i18n;
use AutoLoader qw(AUTOLOAD);
use UNIVERSAL qw(can);
our $VERSION = '0.01';
our $VERSION = '0.1';
sub error {
my($error,$lang) = @_;
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment