javac 12 doesn't support -source 1.6 and -target 1.6, so bump to 1.7

Merged Remi Forax requested to merge make-asm-compatible-with-javac-12 into master

javac 12 doesn't support -source 1.6 and -target 1.6, so bump the classfile version used to compile to 1.7

Merge request reports